Задать вопрос
8 сентября, 08:45

1. Найти s=1+1/2 + 1/3 + 1/4 + ...+1/n, n - вводится с клавиатуры 2. Найти сумму N чисел, вводимых с клавиатуры.

+4
Ответы (1)
  1. 8 сентября, 12:01
    0
    1.

    var n, i:integer; s:real;

    begin

    write ('N=') ; readln (n) ;

    s:=0;

    for i:=1 to n do s:=s+1/i;

    writeln ('S=', s:7:3) ;

    end.

    2.

    var n, i, a, s:integer;

    begin

    write ('N=') ; readln (n) ;

    s:=0;

    for i:=1 to n do

    begin

    write ('a=') ;

    readln (a) ;

    s:=s+a;

    end;

    writeln ('S=', s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Найти s=1+1/2 + 1/3 + 1/4 + ...+1/n, n - вводится с клавиатуры 2. Найти сумму N чисел, вводимых с клавиатуры. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
Найти: а) сумму всех целых чисел от 100 до 500; б) сумму всех целых чисел от a до 500 (значение a вводится с клавиатуры; a 500) ; в) сумму всех целых чисел от - 10 до b (значение b вводится с клавиатуры; b - 10) ;
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)