Задать вопрос
19 марта, 07:45

Паскаль:

Написать программу для определения в двумерном массиве целых чисел D[6,6] максимальный элемент под главной диагональю. Оформить ввод/вывод массива.

+2
Ответы (1)
  1. 19 марта, 11:07
    0
    Var a:array [1 ... 100, 1 ... 100] of integer;

    i, j, max:longint;

    begin

    for i:=1 to 4 do

    for j:=1 to 4 do read (a[i, j]) ;

    max:=a[2,1];

    for i:=1 to 6 do

    for j:=1 to 6 do

    if (a[i, j]>max) and (i>j) then max:=a[i, j];

    for i:=1 to 6 do begin

    for j:=1 to 6 do write (a[i, j],' ') ;

    writeln;

    end;

    writeln ('Максимальный элемент под главной диагональю - ', max) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль: Написать программу для определения в двумерном массиве целых чисел D[6,6] максимальный элемент под главной диагональю. Оформить ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Паскаль 1. В двумерном массиве вычислить A (4,4) найти наибольший элемент, лежащий на главной диагонали. 2. Дан массив A (5,5). Для данного натурального M найти сумму тех элементов массива, сумма индексов которых равна M (М - вводится с клавиатуры).
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Напишите программу, которая находит в массиве максимальный повторяющийся элемент или выводит число - 1, если ни один элемент не повторяется. Входные данные Первая строка содержит размер массива N.
Ответы (1)
Паскаль: Написать программу для определения максимального элемента в одномерном массиве случайных вещественных чисел C[80]. Найти сумму всех элементов. Оформить ввод/вывод массива.
Ответы (1)