Задать вопрос
22 февраля, 00:13

Помогите составить программу и блок-схему к задаче: вычисление площади треугольника по формуле Герона.

+1
Ответы (1)
  1. 22 февраля, 02:53
    0
    Программа без контроля входных данных, т. е. треугольник должет существовать:

    var a, b, c, s, p:real;

    begin

    write ('a=') ; readln (a) ;

    write ('b=') ; readln (b) ;

    write ('c=') ; readln (c) ;

    p: = (a+b+c) / 2;

    s:=sqrt (p * (p-a) * (p-b) * (p-c)) ;

    writeln ('s=', s:6:2) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите составить программу и блок-схему к задаче: вычисление площади треугольника по формуле Герона. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить словесный алгоритм и блок-схему нахождения площади треугольника по формуле Герона, если известны все три стороны
Ответы (1)
Задача_1: Составить программу на языке Паскаль для вычисления выражения y:=sqr (x) + x/3+sqr (sin (x)) Задача_2: Составить программу на языке Паскаль для вычисления площади треугольника по трем сторонам (подсказка: это формула Герона) Задача_3:
Ответы (1)
Известны длины сторон треугольника a, b, c. Написать программу, вычисляющую площадь этого треугольника (по формуле Герона). Выполнить программу для исходных данных a=3, b=4, c=5. Язык Паскаль.
Ответы (1)
Y={0, если х≤0 х, если 0
Ответы (1)
Укажите, что дано и что надо получить: а) вычисление стоимости покупок в магазине б) вычисление суммы сдачи от данных вами продавцу денег в) определение времени показа по телевизору интересующего вас фильма г) вычисление площади треугольника д)
Ответы (1)