Задать вопрос
11 апреля, 04:00

Ввести с клавиатуры натуральное число. Напечатать ДА, если оно состоит из одинаковых цифр, в противном случае напечатать НЕТ. (проверку оформить в виде процедуры или функции)

Помогите решить в PascalABC

+5
Ответы (1)
  1. 11 апреля, 05:04
    0
    Function IsSame (n:integer) : string;

    var

    i:integer;

    begin

    IsSame:='Да';

    while n>=10 do

    if (n mod 10) ((n div 10) mod 10) then

    begin

    IsSame:='Нет';

    exit;

    end

    else

    n:=n div 10;

    end;

    var

    n:integer;

    begin

    readln (n) ;

    writeln (IsSame (n)) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Ввести с клавиатуры натуральное число. Напечатать ДА, если оно состоит из одинаковых цифр, в противном случае напечатать НЕТ. (проверку ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
Помогите написать программу Паскаль, очень прошу, вообще не шарю в программах, а так 2 поставят! Задача "A": Ввести натуральное число и найти сумму его цифр. Пример: Введите натуральное число: 12345. Сумма цифр 15.
Ответы (2)
1. Переведите на язык программирования: а) ввести А и С увеличить А в 10 раз уменьшить С в 20 раз напечатать модуль разности А и С б) ввести А и С если А>С, то увеличить А в 5 раз иначе уменьшить С в 2 раза напечатать значения А и С конец в) ввести
Ответы (1)
Дано число. Если оно делится на 11, то уменьшить ч Дано число. Если оно делится на 11, то уменьшить число в 11 раз, в противном случае уменьшить число на 11. исло в 11 раз, в противном случае уменьшить число на 11.
Ответы (1)
Помогите с прогой. Паскаль. Ввести массив, ввести кол-во элементов в массиве (не через рандом). Ввести число. Найти сколько элементов равны этому числу. (ввод массива и кол-ва эл. Через процедуры)
Ответы (1)