Задать вопрос
20 апреля, 20:50

Составие программу, которая печатает "да", если слово содержит букву"е" и "нет", если не содержит. отладку выполнить для слов : "предмет" и "колонна"

+1
Ответы (2)
  1. 21 апреля, 00:09
    0
    Var

    s, a: string;

    i: integer;

    begin

    readln (s) ;

    {первый вариант}

    a : = 'Нет';

    for i : = 1 to length (s) do

    if (s[i] = 'e') or (s[i] = 'е') then begin

    a : = 'Да';

    break;

    end;

    writeln (a) ;

    {второй вариант}

    if (Pos ('e', s) > 0) or (Pos ('е', s) > 0) then

    writeln ('Да')

    else writeln ('Нет') ;

    end.
  2. 21 апреля, 00:21
    0
    Var x:string; k, i:integer;

    begin

    k:=0;

    read (x) ;

    for i:=1 to length (x) do begin

    if copy (x, i, 1) = 'е' then k:=k+1;

    end;

    if k>0 then writeln ('Да') else writeln ('Нет') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составие программу, которая печатает "да", если слово содержит букву"е" и "нет", если не содержит. отладку выполнить для слов : "предмет" и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
С++ Написать программу, которая переводит число из 9-й системы счисления в 3-ю, не переводя все число в 10-ю. Выполнить отладку программы с помощью какого-либо примера, подготовленного Вами на бумаге.
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Написать программу, которая грамотно печатает фразу "У меня К друзей". К вводится с клавиатуры. Например, для К=1 должно напечататься " У меня 1 друг", для К=24 - "У меня 24 друга", для К=100 - "У меня 100 друзей". написать программу в paskal
Ответы (1)
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)