Задать вопрос
2 августа, 10:00

В линейном массиве определить минимальный элемент из элементов массива, имеющих нечетные номера

+3
Ответы (1)
  1. 2 августа, 13:08
    0
    Const

    handsfree = true;

    var

    a: array[1 ... 100] of real;

    i, n: integer;

    min: real;

    begin

    {ввод массива}

    if handsfree then

    n : = random (20) + 5

    else begin

    write ('n = ') ;

    readln (n) ;

    end;

    writeln ('Данные массива:') ;

    for i : = 1 to n do

    begin

    if handsfree then begin

    a[i] : = random (100) ;

    write (a[i], ' ') ;

    end

    else readln (a[i]) ;

    end;

    writeln () ;

    {минимум и максимум}

    min : = a[1];

    for i : = 1 to n do

    begin

    if (min > a[i]) and (i mod 2=1) then min : = a[i];

    end;

    writeln ('min = ', min) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В линейном массиве определить минимальный элемент из элементов массива, имеющих нечетные номера ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Паскаль! Дан массив А размерностью N. Записать в каждый элемент массива В следующие значения: 1 ый элемент - сумма всех нечетных элементов массива А; 2 ои элемент - сумма всех четных элементов массива А: Зий элемент - сумма всех элементов массива А
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
Что определяет для массива X[1 ... n] следующий алгоритм P: = 0; For k: = 1 to n do If X[k]
Ответы (1)
Паскаль. Вычислить разность максимального среди элементов, имеющих четные значения, и максимального среди элементов, имеющих нечетные значения, в заданном целочисленном массиве из 30 положительных элементов (в предположении, что в массиве есть и
Ответы (1)