Задать вопрос
13 апреля, 12:12

Создание программы. Ввести фамилию имя отчество как одно текстовое данное. Вывести фамилия имя отчество в отдельных строках.

+5
Ответы (1)
  1. 13 апреля, 15:38
    0
    Если фамилия, имя и отчество вводятся через пробел, то задачу можно решить так:

    var s, f, i:string;

    begin

    writeln ('Введите ФИО') ;

    readln (s) ;

    f:=copy (s, 1, pos (' ', s) - 1) ;

    writeln (f) ;

    delete (s, 1, pos (' ', s)) ;

    i:=copy (s, 1, pos (' ', s) - 1) ;

    writeln (i) ;

    delete (s, 1, pos (' ', s)) ;

    writeln (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Создание программы. Ввести фамилию имя отчество как одно текстовое данное. Вывести фамилия имя отчество в отдельных строках. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Программы с процедурой вставки В строку s1 занесите свои фамилию и отчество (через пробел). В строку s2 занесите свое имя. С помощью процедуры вставки измените строку s1 таким образом, чтобы она содержала Ваши фамилию, имя, отчество.
Ответы (1)
С клавиатуры вводят строку Фамилия Имя Отчество Нужно составить программу, которая выводит а) "Имя Фамилия Отчество" - именно этот порядок б) "Фамилия Имя"
Ответы (1)
В поездке пятеро друзей - Сергей, Пётр, Андрей, Виктор, Николай - знакомились с попутчицей. Они предложили ей отгадать их фамилии, причём каждый из них высказал одно истинное и одно ложное утверждение.
Ответы (1)
Ввести имя, отчество и фамилию. Преобразовать их к формату "фамилия-инициалы". Ввести символьную строку и заменить все буквы "а" на буквы "б" и наоборот, как заглавные, так и строчные.
Ответы (1)
1. Как в Pscal ABC ввести с клавиатуры фамилию, имя, отчество в одну строку? 2. Как в Pascal ABC ввести с клавиатуры 2 целых числа и вывести на экран выражение вида: d=a+b, где а и b-значения величин: а=2, b=1. Вывод 3=2+1
Ответы (1)