Задать вопрос
17 апреля, 21:21

Найти произведение четных чисел от - 100 до 100 паскаль

+5
Ответы (1)
  1. 17 апреля, 22:28
    0
    Ответ: 0

    Т. к. среди чисел произведения будет встречен ноль (который является чётным числом), который всё и занулит.

    Var

    i : Integer;

    m : Longint;

    Begin

    m:=1;

    For i:=-100 to 100 do If not Odd (i) then m:=m*i;

    Writeln (m) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти произведение четных чисел от - 100 до 100 паскаль ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Помогите решить задачи в паскале. 1) найти сумму положительных элементов массива. 2) найти сумму четных элементов массива. 3) найти сумму всех четных элементов массива, стоящих на четных местах.
Ответы (1)
Дано N. Найти произведение четных чисел этого числа. Решить с помощью паскаля. Ребят, у меня вышла такая программа: Program Pr1; var n, p, m:integer; begin write ('n=') ; readln (n) ; m:=n; p:=1;
Ответы (1)
Написать программу на языке паскаль. С клавиатуры вводятся несколько натуральных целых чисел. Необходимо чтобы вычислялось сколько введено чисел, сколько из них четных и общая сумма этих чисел.
Ответы (1)