Задать вопрос
7 марта, 23:40

Напишите программу на языке паскаль. богатый и бедный заключили спор. богатый отдает каждый день 100 в течение месяца. бедный отдает в первый день копейку каждый следующий день в 2 раза больше в течение месяца, кто выграет спор

+4
Ответы (1)
  1. 8 марта, 03:14
    0
    Var m1, m2, st, i:integer;

    begin

    m1:=0; m2:=0;

    st:=1;

    for i:=1 to 30 do

    begin

    m1:=m1+100;

    m2:=m2+st;

    st:=st*2;

    end;

    writeln ('Богатый: ', m1,' бедный: ', m2) ;

    if m1
    then writeln ('Выиграл богатый') else writeln ('Выиграл бедный') ;

    end.

    Результат:

    Богатый: 3000 бедный: 1073741823

    Выиграл богатый
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу на языке паскаль. богатый и бедный заключили спор. богатый отдает каждый день 100 в течение месяца. бедный отдает в ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите задачу на языке паскаль. бедный и богатый заключили спор. Богач отдает каждый день 100 рублей в течение месяца. Бедный отдает в первый день копейку каждый следующий день в 2 раза больше. в течение месяца, кто победит спор?
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Задача_1: Составить программу на языке Паскаль для вычисления выражения y:=sqr (x) + x/3+sqr (sin (x)) Задача_2: Составить программу на языке Паскаль для вычисления площади треугольника по трем сторонам (подсказка: это формула Герона) Задача_3:
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Домашнее задание: 1. Запишите на языке Паскаль программу, которая для произвольного двузначного числа определяет сумму и произведение его цифр. 2.
Ответы (1)