Задать вопрос
20 августа, 16:34

Напишите задачу на языке паскаль.

бедный и богатый заключили спор. Богач отдает каждый день 100 рублей в течение месяца. Бедный отдает в первый день копейку каждый следующий день в 2 раза больше. в течение месяца, кто победит спор?

+4
Ответы (1)
  1. 20 августа, 16:43
    0
    Var a, b:real;

    i, d:integer;

    begin

    a:=0;

    b:=0;

    d:=1;

    for i:=1 to 30 do begin

    a:=a+100;

    b:=b+d;

    d:=d*2;

    end;

    b:=b/100;

    if a>b then writeln ('Богач отдал больше') else writeln ('Бедный отдал больше') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите задачу на языке паскаль. бедный и богатый заключили спор. Богач отдает каждый день 100 рублей в течение месяца. Бедный отдает в ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу на языке паскаль. богатый и бедный заключили спор. богатый отдает каждый день 100 в течение месяца. бедный отдает в первый день копейку каждый следующий день в 2 раза больше в течение месяца, кто выграет спор
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Команды четырех соседних школ соревновались в волейбольном турнире. Болельщики поделились своими предположениями: 1-й болельщик: 556-я победит, а 450-я будет второй. 2-й болельщик: нет, 556-я будет последней, а вот победит 324-я.
Ответы (1)
Задача_1: Составить программу на языке Паскаль для вычисления выражения y:=sqr (x) + x/3+sqr (sin (x)) Задача_2: Составить программу на языке Паскаль для вычисления площади треугольника по трем сторонам (подсказка: это формула Герона) Задача_3:
Ответы (1)