Задать вопрос
3 января, 07:45

Дано число n проверить есть ли в записи 3 одинаковых числа (число не больше 10 000)

+3
Ответы (1)
  1. 3 января, 11:37
    0
    Var A:array[1 ... 5] of Integer;

    j, l, i, k, N:integer;

    begin

    Readln (N) ;

    While not (N=0) do

    begin

    k:=k+1;

    A[k]:=N mod 10;

    N:=N div 10;

    end;

    For i:=1 to min (3, k) do

    begin

    N:=A[i];

    l:=0;

    For j:=1 to k do

    If N=A[j] then

    l:=l+1;

    If l>=3 then

    begin

    Writeln ('В записи есть три одинаковых чисел') ;

    l:=20;

    break;

    end;

    end;

    If not (l=20) then

    Writeln ('В записи нет трех одинаковых чисел') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано число n проверить есть ли в записи 3 одинаковых числа (число не больше 10 000) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
754 000 000 000 000 000 000 в нормализованной форме? 0,000 000 000 000 022 865 в нормализованной форме?
Ответы (1)
Сколько работает примерно серверов в мире 1) 100 000 2) 10 000 000 3) 1 000 000 000 4) 100 000 000 000
Ответы (1)
Сколько мегабайт в гигабайте, если в одном мегабайте 1 000 000 байт, а в одном гигабайте 1 000 000 000 байт? Сколько килобайт в мегабайте, если в одном килобайте 1000 байт, а в одном мегабайте 1 000 000 байт? Народ, помогите!
Ответы (2)
1) Сколько единиц в двоичной записи числа 67,5? 2) Сколько единиц в двоичной записи числа 23,375? 3) Сколько значащих нулей в двоичной записи числа 19,125? 4) Сколько значащих нулей в двоичной записи числа 37,875?
Ответы (1)
Придумайте натуральное число которое удовлетворяет следущим условиям: 1. Запись числа состоит из 7 цифр 2. Сумма всех цифр числа равна 39. 3. В записи числа есть хотя бы одна цифра 4 4. В записи числа есть хотя бы одна цифра 7 5.
Ответы (1)