Задать вопрос
5 июня, 19:30

Требуется найти самую длинную непрерывную цепочку нулей в последовательности нулей и единиц.

Пример: 00101110000110 Ответ: 4;

Программу нужно написать на Паскале

+3
Ответы (2)
  1. 5 июня, 21:14
    0
    Var s: string;

    bg, k, i, l: integer;

    begin

    write ('строка: ') ;

    readln (s) ;

    i:=1; bg:=0; k:=0;

    l:=length (s) ;

    while (i
    begin

    while (s[i]'0') and (i
    bg:=i;

    while (s[i]='0') and (i
    if i=l then bg:=bg-1;

    if k
    end;

    writeln ('длина макс. последоват. из нулей = ', k) ;

    end.
  2. 5 июня, 23:05
    0
    Надеюсь вам можно использовать массивы, если нет, то скажите, переделаем
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Требуется найти самую длинную непрерывную цепочку нулей в последовательности нулей и единиц. Пример: 00101110000110 Ответ: 4; Программу ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан массив с1, с2, ..., с15, состоящий из нулей и единиц. Подсчитать количество нулей, количество единиц и количество нулей до первой единицы. Это в паскале
Ответы (1)
Напечатайте слово-палиндром, содержащее самую длинную цепочку из цифр. в паскале
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Помогите решить задачу на c++. Последовательность из нулей и единиц четной длины назовем справедливой, если на четных местах этой последовательности столько же единиц, сколько на нечетных.
Ответы (1)
Напишите программу на паскале, которая 1) сначала определит по введенному двузначному числу цифру десятков и цифру единиц. 2.1) Если цифра десятков меньше цифры единиц, то программа выведет двузначное число, состоящее из. цифр единиц.
Ответы (1)