Задать вопрос
3 декабря, 10:30

Паскаль построить программу. Циклический алгоритм. a (a-1) (a-2) (a-3) ... (a-n)

+3
Ответы (1)
  1. 3 декабря, 12:09
    0
    Var n, a, res:integer;

    i:integer;

    begin

    n:=1;

    write ('Введите N:') ; readln (n) ;

    write ('Введите a:') ; readln (a) ;

    res:=a;

    for i:=1 to n do

    begin

    res : = res * (a-i) ;

    end;

    writeln ('Ответ:', res) end.

    Пример:

    Введите N:2

    Введите a:4

    Ответ: 24
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль построить программу. Циклический алгоритм. a (a-1) (a-2) (a-3) ... (a-n) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
исключи из предложенных сочетаний слов те, которые невозможны в информатике: 1) линейный алгоритм 2) прямой алгоритм 3) циклический алгоритм 4) разветвляющийся алгоритм
Ответы (2)
К какому виду алгоритма относится решение линейного уравнение? А) линейный алгоритм В) Развлетвляющийся алгоритм С) Циклический алгоритм Д) лабиринт Е) Оператор алгоритм
Ответы (1)
Циклический алгоритм - это: А. алгоритм с повторяющейся частью B. Алгоритм, в котором выполнение действий зависит от поставленного условия C. Последовательное выполнение действий D.
Ответы (1)
Нужно сделать блок-схему, алгоритм и написать программу QBasic Задача - Найти произведение однозначных положительных цифр. (это циклический алгоритм) цифры - 1,2,3 ... 9
Ответы (1)