Задать вопрос
17 декабря, 15:19

Напишите программу в которой одномерный массив на 10 элементов, нужно заполнить по формуле только четными значениями. Выведите массив строчку. Найдите количество значений лежащих в промежутке [6 до 20] (включительно 20). Произведение тех, которые больше 10

+2
Ответы (1)
  1. 17 декабря, 15:47
    0
    Var A:array[1 ... 10] of Integer;

    i, N, k, l, j:integer;

    begin

    Readln (N) ;

    For i:=1 to N do

    A[i]:=Random (1,10) ;

    For i:=1 to N do

    Write (A[i],' ') ;

    Writeln;

    For i:=1 to N do

    If (A[i]>=6) and (A[i]<=20) then

    k:=k+1;

    Writeln ('количество значений лежащих в промежутке [6 до 20] ', k) ;

    For i:=1 to N-1 do

    For j:=i+1 to N do

    If A[i]*A[j]>10 then

    l:=l+1;

    Writeln ('количество значений п роизведение которых больше 10 ', l) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу в которой одномерный массив на 10 элементов, нужно заполнить по формуле только четными значениями. Выведите массив ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
С # 1. Создайте одномерный массив с 31 элементов, которые заполните случайными целыми числами от 11 до 100-11. Выведите значения элементов массива в строку, разделив их пробелами, 11 нечетное число.
Ответы (1)
2. Задать двумерный массив (4 х4) случайными значениями от 12 до 18 включительно. Вывести сумму значений элементов каждого столбца матрицы. 3. Задать двумерный массив (7 х7) случайными значениями от 12 до 18 включительно.
Ответы (1)