Задать вопрос
21 июня, 23:12

Построить матрицу B, поменяв местами строки и столбцы в Паскале

+4
Ответы (1)
  1. 22 июня, 01:02
    0
    Var a, b:array[1 ... 3,1 ... 3] of integer;

    i, j:integer;

    begin;

    randomize;

    writeln ('First matrix') ;

    for i:=1 to 3 do

    begin;

    writeln;

    for j:=1 to 3 do

    begin;

    a[i, j]:=random (9) ;

    write (a[i, j]:4) ;

    b[j, i]:=a[i, j];

    end;

    end;

    writeln;

    writeln ('Final matrix') ;

    for i:=1 to 3 do

    begin;

    writeln;

    for j:=1 to 3 do

    write (b[i, j]:4) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Построить матрицу B, поменяв местами строки и столбцы в Паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задана квадратная матрица. Получить транспонированную матрицу, т. е. матрицу, где столбцы и строки меняются местами. Программа на Паскаль.
Ответы (1)
Помогите, не могу понять, как повернуть матрицу на 90 градус. Сформировать матрицу 4*4, рандомно заполнить, вывести исходную матрицу, а затем повернуть её на 90 градусов и снова вывести. на языке Pascal
Ответы (1)
Паскаль! Заполнить матрицу размерностью N на M по следующему принципу: Если номер строки больше номера столбца, то элемент равен номеру строки. Иначе - элемент равен произведению индексов. Выведите матрицу на экран.
Ответы (1)
Дана матрица размера 5 x 10 заполненная целыми числами. Преобразовать эту матрицу, поменяв местами минимальный и максимальный элемент в каждой строке. Дайте оценку сложности построенного алгоритма. (pascal abc)
Ответы (1)
Написать программу в Паскале. Ввести матрицу. Найти сумму s1 положительных элементов и сумму s2 отрицательных элементов над и под главной диагональю. Если s1>s2, то 1-ую и последнюю строки заменить на s1, иначе 1-ый и последний столбец на s2.
Ответы (1)