Задать вопрос
15 января, 03:25

Напишите программу, которая считает количество четных цифр введенного числа

+2
Ответы (1)
  1. 15 января, 05:25
    0
    Var

    s:string;

    i, n:longint;

    begin

    readln (s) ;

    for i:=1 to length (s) do

    if (s[i]='2') or (s[i]='4') or (s[i]='6') or (s[i]='8') then inc (n) ;

    writeln (n) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая считает количество четных цифр введенного числа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
1. Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом. 2. Составьте программу, которая определяет, является ли последняя цифра введенного целого числа нечетным числом. 8 класс.
Ответы (1)
Напишите программу, которая считает сумму цифр введенного числа (паскаль)
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, сумму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b
Ответы (1)