Задать вопрос
29 ноября, 11:00

Free Pascal. Нужно написать программу, где после каждой буквы Ch вставляется строка Str1.

+3
Ответы (2)
  1. 29 ноября, 12:46
    0
    Var

    s, str1:string;

    ch:char;

    i:integer;

    begin

    Write ('Введите текст: ') ; ReadLn (s) ;

    Write ('Введите искомый символ: ') ; Readln (ch) ;

    Write ('Введите добавляемый текст: ') ; Readln (str1) ;

    for i:=Length (s) downto 1 do

    if s[i]=ch then Insert (str1, s, i+1) ;

    Writeln ('Результат: ', s) ;

    Readln;

    end.

    Тестовое решение:

    Введите текст: А роза упала на лапу Азора

    Введите искомый символ: а

    Введите добавляемый текст: 12345

    Результат: А роза12345 упа12345 ла12345 на12345 ла12345 пу Азора12345
  2. 29 ноября, 14:20
    0
    program Project4;

    var ch:char; str, str1, str2:string; i:integer;

    begin

    writeln ('Введите исходный текст:') ;

    readln (str) ;

    writeln ('Введите строку которую нужно вставить:') ;

    readln (str1) ;

    writeln ('Введите символ после которого нужно вставить:') ;

    readln (ch) ;

    str2:='';

    i:=pos (ch, str) ;

    while i>0 do begin

    str2:=str2+copy (str, 1, i) + str1;

    delete (str, 1, i) ;

    i:=pos (ch, str) ;

    end;

    writeln ('Результирующая строка: ', str2) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Free Pascal. Нужно написать программу, где после каждой буквы Ch вставляется строка Str1. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Синвейн про информатику (1 строка информатика 2 строка два прилагательных 3 строка три глагола 4 строка фраза, несущая определённый смысл 5 строка вывод в одном слове) Стоки не должны рифмоваться
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
Дана матрица размера M х N. Вывести ее элементы в следующем порядке: первая строка слева направо, вторая строка справа налево, третья строка слева направо, четвертая строка справа налево и т. д. в c++, code blocks
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)