Задать вопрос
22 июля, 06:48

Pascal ABC

Задача с while, for, if.

На промежутке от a до b найти все числа и их количество (k), которые делятся на сумму (s) своих цифр.

Тест:

10 20

10 12 18 20

4

+5
Ответы (1)
  1. 22 июля, 07:32
    0
    Var

    a, b, i, j, k, s:integer;

    begin

    write ('a=') ; readln (a) ;

    write ('b=') ; readln (b) ;

    k:=0;

    for i:=a to b do

    begin

    j:=i;

    s:=0;

    while (j>0) do

    begin

    s:=s + (j mod 10) ;

    j:=j div 10;

    end;

    if (i mod s) = 0 then

    begin

    write (i,' ') ;

    inc (k) ;

    end;

    end;

    writeln;

    writeln ('k=', k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Pascal ABC Задача с while, for, if. На промежутке от a до b найти все числа и их количество (k), которые делятся на сумму (s) своих цифр. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Работаем в Pascal ABC 1. Найти количество цифр меньше 6 в целом x. Тест: 254904 - 5 2. Найти сумму первой и последней цифры в целом x. Тест: 254904 - 6 3. Найти сумму самой большой и самой маленькой цифры в целом x Тест: 254904 - 9
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Из ряда натуральных чисел от 1 до 2000 вычеркнули все числа, которые делятся на 2, затем все числа, которые делятся на 3, затем все числа, которые делятся на 5, а затем все числа, которые делятся на 7. Сколько чисел осталось?
Ответы (1)
Из ряда натуральных чисел от 1 до 1500 вычеркнули все числа, которые делятся на 2, затем все числа, которые делятся на 3, затем все числа, которые делятся на 5, а затем все числа, которые делятся на 7. Сколько чисел осталось?
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)