Задать вопрос
30 сентября, 12:34

Вычислить сумму и кол-во 4-х значных чисел кратных 5 и имеющих в серединке две цифры "2" в паскале

+2
Ответы (1)
  1. 30 сентября, 14:22
    0
    Var

    i, s, m: integer;

    begin

    for i : = 1000 to 9999 do

    begin

    if (i div 10 mod 10 = 2) and (i div 100 mod 10 = 2) then begin

    s:=s+i;

    m:=m+1;

    end;

    end;

    writeln ('Сумма-', s,' Кол-во-', m) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вычислить сумму и кол-во 4-х значных чисел кратных 5 и имеющих в серединке две цифры "2" в паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Вычислить сумму и кол-во 4-х значных чисел кратных 5 и имеющих в серединке две цифры "2"
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
поставьте знаки арифметических операций в каждой схеме. А) скорость? время=путь б) путь? время=скорость в) масса 1 батона? количество батонов=общ. масса г) кол. батонов? кол. буханок=общ. кол. д) кол. конфет в 1 коробке? кол. коробок = общ. кол.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)
1) Вывести на экран числа кратные 16 от 31 до M (M>31) ; 2) Найти сумму 5 натуральных чисел кратных 13; 3) Найти произведение N натуральных чисел кратных 11; 4) Вывести на экран семь первых чисел кратных 7.
Ответы (1)