Задать вопрос
1 ноября, 16:27

Напишите программу в Паскале, которая определяет среднее арифметическое чисел в интервале от N до N1

+4
Ответы (1)
  1. 1 ноября, 18:25
    0
    Var N, N1, Sum, i: integer;

    begin

    readln (N, N1) ;

    for i : = N to N1 do Sum : = Sum + i;

    writeln (sum / (n1 - n + 1)) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу в Паскале, которая определяет среднее арифметическое чисел в интервале от N до N1 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В Паскале: 1. Составить функцию и процедуру, которая определяет сумму всех чисел от 1 до N. 2. Составить программу, которая определяет НОД и НОК двух чисел.
Ответы (1)
1) Найти сумму нечетных чисел на интервале [-30; 40]. 2) Найти кол-во чисел на интервале [-50; 120], которые кратны 9. 3) Найти произведение чисел кратных 11 на интервале [-10; 20]. 4) Последовательно вводятся N чисел. Найти их произведение.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)