Задать вопрос
4 ноября, 21:44

Составьте программ, которая заполняет массив а[1 ... 12] случайными целыми числами в диапазоне от 1 до 11, затем преобразовывает его, возводя в квадрат все элементы с четными числами

+1
Ответы (2)
  1. 4 ноября, 23:38
    0
    Var ar:array[1 ... 12] of integer;

    i:integer;

    begin;

    randomize;

    writeln ('Main array:') ;

    for i:=1 to 12 do

    begin;

    ar[i]:=random (1,11) ;

    writeln (ar[i]) ;

    end;

    writeln ('Changed array:') ;

    for i:=1 to 12 do

    begin;

    if ar[i] mod 2=0 then ar[i]:=sqr (ar[i]) ;

    writeln (ar[i]) ;

    end;

    end.
  2. 5 ноября, 00:17
    0
    Uses crt;

    Var mas:array[1 ... 12]of integer;

    a:integer;

    Begin

    randomize;

    for a:=1 to 12 do

    begin

    mas[a]:=random (11) + 1;

    end;

    For a:=1 to 12 do

    begin

    Write (mas[a]:1,' ') ;

    end;

    for a:=1 to 12 do

    begin

    if (mas[a] mod 2 = 0) then mas[a]:=sqr (mas[a]) ;

    end;

    Writeln () ;

    For a:=1 to 12 do

    begin

    Write (mas[a]:1,' ') ;

    end;

    Writeln () ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программ, которая заполняет массив а[1 ... 12] случайными целыми числами в диапазоне от 1 до 11, затем преобразовывает его, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Составте программуб которая заполняет массив а[1 ... 10] случайными целыми числами в диапозоне от 1 до 10, затем преобразовывает его, увеличивая все элементы с четными значениями на 1.
Ответы (1)
1. Cоставьте программу, которая заполняет массив a [1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем преобразовывает его, увеличивая все элементы с чётными значениями на 1.
Ответы (1)
составьте программу, которая заполняет массив А:[1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем преобразовывает его, возводя в квадрат все элементы с четными индексами
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
А) Составьте программу, которая заполняет массив В[1 ... 11] случайными целыми числами в диапазоне от - 5 до 5 и преобразовывает его, заменяя элементы кратные 5 на 5, а остальные увеличивая в 5 раз.
Ответы (1)