Задать вопрос
7 июля, 15:56

Задание: написать программу, вычисляющую произведение элементов одномерного массива Z (N).

Рекомендация: посмотрите алгоритм нахождения суммы и обратите внимание на то, что произведение P:=P*Z[k] перед циклическим процессом нужно задать как 1, т. е. P:=1;

Ввод и вывод массива выполните через текстовый файл.

+4
Ответы (1)
  1. 7 июля, 18:56
    0
    Var Z:array[1 ... 100] as integer; P:integer; i, n:integer; begin Reset (input,'input. txt') ; Rewrite (output,'output. tx) ; readln (n) ; For i:=1 to n do Readln (Z[i]) ; P:=1; For i:=1 to n do P:=p*z[i]; Writeln (p) ; Close (input) ; Close (output) ; end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задание: написать программу, вычисляющую произведение элементов одномерного массива Z (N). Рекомендация: посмотрите алгоритм нахождения ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сделать программу в Pascal. 1. Организуйте ввод и вывод одномерного массива в строку, в столбец. 2. Найдите произведение ненулевых элементов одномерного массива. 3.
Ответы (1)
Помогите! 1. Web-страница (документ html) представляет собой: 1) текстовый файл с расширением txt или doc 2) текстовый файл с расширением htm или html 3) двоичный файл с расширением com или exe 4) графический файл с расширением gif или jpg
Ответы (2)
Написать программу, позволяющую для заданного одномерного массива А из n вещественных или целых элементов реализовать обработку массива. Длина массива N задается пользователем как константное выражение.
Ответы (1)
Задание #1 Напиши программу, вычисляющую периметр и площадь прямоугольника. Используй для этого длину и ширину прямоугольника, которые вводятся с клавиатуры.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)