Задать вопрос
25 мая, 20:26

Написать программу: Дано 5 произвольных натуральных чисел. Найти среднее арифметическое отрицательных кратных пяти.

+1
Ответы (1)
  1. 26 мая, 00:14
    0
    Program z1;

    var

    mas: array[1 ... 10] of integer;

    i, s, sr, k: integer;

    begin

    s:=0;

    k:=0;

    writeln ('Введите 5 чисел') ;

    for i:=1 to 5 do

    begin

    readln (mas[i]) ;

    if (mas[i]<0) and (mas[i] mod 5=0) then

    begin

    s:=s+mas[i];

    k:=k+1;

    end;

    end;

    sr:=s div k;

    writeln ('Среднее арифметическое чисел, кратных 5, равно ', sr) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу: Дано 5 произвольных натуральных чисел. Найти среднее арифметическое отрицательных кратных пяти. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
20.2 (№ 987) Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое чисел, кратных 8, или сообщает, что таких чисел нет (выводит "NO").
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
Напишите программу, которая в последовательности целых чисел находит среднее арифметическое чисел, кратных 9, или сообщает, что таких чисел нет.
Ответы (1)
1) Вывести на экран числа кратные 16 от 31 до M (M>31) ; 2) Найти сумму 5 натуральных чисел кратных 13; 3) Найти произведение N натуральных чисел кратных 11; 4) Вывести на экран семь первых чисел кратных 7.
Ответы (1)