Задать вопрос
25 ноября, 17:10

Найти количество положительных (отрицательных) чисел среди четырех чисел А, В, С, D

+3
Ответы (1)
  1. 25 ноября, 20:22
    0
    Var a, b, c, d:integer;

    begin

    readln (a, b, c, d) ;

    if a>0 then p:=p+1;

    if a<0 then o:=o+1;

    if b>0 then p:=p+1;

    if b<0 then o:=o+1;

    if c>0 then p:=p+1;

    if c<0 then o:=o+1;

    if d>0 then p:=p+1;

    if d<0 then o:=o+1;

    writeln ('Положительных чисел:', p,', отрицательных:', o)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти количество положительных (отрицательных) чисел среди четырех чисел А, В, С, D ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Подсчитайте, сколько среди данных N чисел нулей, положительных чисел, отрицательных чисел. Вводится число N, а затем N чисел. Необходимо вывести сначала число нулей, затем число положительных и отрицательных чисел.
Ответы (1)
Дано массив с N положительных и отрицательных чисел. а) найти среднее аримфметичкое отдельно для положительных, среднее геометрическое - для негативных. б) найти максимальную по длинне последовательность чисел с одинаковым знаком.
Ответы (1)
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов 2) Дан массив целых чисел.
Ответы (1)
определить среди 3 введенных чисел (a, b, c) количество отрицательных и положительных. Если больше отрицательных то найти произведение этих 3 чисел, а иначе найти max из трех
Ответы (1)
Определить среди 3 введенных чисел (a, b, c) количество отрицательных и положительных. Если больше положительных, то найти минимум из этих 3 чисел, а иначе найти максимум. (нужно нарисовать блок схему и написать программу в паскале)
Ответы (1)