Задать вопрос
21 июля, 04:15

Дан двумерный массив. сформировать одномерный массив из минимальных элементов каждой строки. pascal

+5
Ответы (1)
  1. 21 июля, 07:40
    0
    Var a: array[1 ... 10,1 ... 10] of Integer;

    b: array[1 ... 10] of Integer;

    i, j, min: Integer;

    Begin

    for i : = 1 to 10 do

    begin

    min : = 10;

    for j : = 1 to 10 do

    begin

    a[i, j] : = random (10) ;

    write (a[i, j],' ') ;

    if a[i, j] < min then min : = a[i, j];

    end;

    b[i] : = min;

    writeln;

    end;

    writeln;

    for i : = 1 to 10 do

    write (b[i],' ') ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан двумерный массив. сформировать одномерный массив из минимальных элементов каждой строки. pascal ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Visual basic 1. Сформировать одномерный массив из восьми вещественных значений. 2. Сформировать двумерный массив из А строк и В столбцов. 3. Составить программу для определения максимального и минимального элементов двумерного массива. 4.
Ответы (1)
Дан одномерный массив. Из элементов массива равных 100, сформировать массив b., а из элементов меньших 33, сформировать массив с.
Ответы (1)
1. Дан одномерный массив из N элементов. Заменить в нем значение макс и мин элемента на сумму всех элементов массива 2. Дан одномерный массив из Н элементов. Найти среднее арифметическое положительных четных элементов данного массива
Ответы (1)
Сформировать двумерный массив А размером 5*7 с помощью генератора случайных чисел и вывести элементы массива на экран. Найти суммы положительных элементов каждой строки матрицы и записать их в одномерный массив В. Вывести элементы массива В на экран.
Ответы (1)