Задать вопрос
26 ноября, 20:57

Массив m (8) заполнен с клавиатуры целыми числами в диапазоне от - 15 до + 10. Числа меньшие - 5 увеличить в 3 раза, а числа, большие 7 в 5 раз. Исходный и новый массивы вывести в виде матриц.

+5
Ответы (1)
  1. 26 ноября, 23:01
    0
    Var

    a:array[1 ... 8] of integer;

    b:array[1 ... 8] of integer;

    i:integer;

    begin

    write ('Заполните массив - ') ;

    for i:=1 to 8 do

    read (a[i]) ;

    for i:=1 to 8

    do

    begin

    if a[i]< (-5) then b[i]:=a[i]*3

    else

    begin

    if a[i]>7 then b[i]:=a[i]*5

    else b[i]:=a[i];

    end;

    end;

    for i:=1 to 8 do

    write (a[i],' ') ;

    writeln () ;

    for i:=1 to 8 do

    write (b[i],' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Массив m (8) заполнен с клавиатуры целыми числами в диапазоне от - 15 до + 10. Числа меньшие - 5 увеличить в 3 раза, а числа, большие 7 в 5 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
A) Составьте программу, которая заполняет масcив a[10 ... 20] случайными целыми числами в диапазоне от 10 до 20, затем меняет местами первый и последний элементы. Выведите на экран исходный и полученный массивы.
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
Ввести с клавиатуры одномерный массив, состоящий из 10 элементов и записать сначала все элементы кратные 5, а затем все оставшиеся. На экран вывести исходный и новый массивы в две строки. Отсортировать новый массив методом "пузырька".
Ответы (1)
А) Составьте программу, которая заполняет массив В[1 ... 11] случайными целыми числами в диапазоне от - 5 до 5 и преобразовывает его, заменяя элементы кратные 5 на 5, а остальные увеличивая в 5 раз.
Ответы (1)