Задать вопрос
13 мая, 20:45

Программа, которая выводит числа, которые делятся на 3 но не делятся на 6

+1
Ответы (1)
  1. 14 мая, 00:26
    0
    Это в том случае, когда нужно, чтобы компьютер сам выдавал рандомные числа:

    var

    a:array [1 ... 100] of integer;

    i: integer;

    begin

    for i:=1 to 100 do begin

    a[i]:=random (100) - 50;

    if (a[i] mod 3=0) and (a[i] mod 60) then

    write (a[i]) ; end;

    end.

    если же есть определенный ряд чисел, то программа будет выглядеть вот так:

    var

    a:array [1 ... 100] of integer;

    i, n: integer;

    begin

    read (n) ; - здесь вводим кол-во чисел.

    for i:=1 to n do begin

    read (a[i]) ; - вводим числа с клавиатуры.

    if (a[i] mod 3=0) and (a[i] mod 60) then

    write (a[i], ' ') ; end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Программа, которая выводит числа, которые делятся на 3 но не делятся на 6 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая работает с двумя целыми числами, введёнными с клавиатуры. Программа выводит все чётные числа, расположенные в интервале между двумя введёнными числами.
Ответы (1)
Паскаль ABC Пользователь вводит с клавиатуры два числа. Если сумма чисел больше, либо равна 100, то программа выводит "Разряд выше десятков", если сумма меньше 100, но больше либо равна 10, то программа выводит "Разряд выше единиц", если сумма чисел
Ответы (1)
Дано три числа. Упорядочите их в порядке неубывания. Программа должна считывать три числа a, b, c, затем программа должна менять их значения так, чтобы стали выполнены условия a < = b < = c, затем программа выводит тройку a, b, c.
Ответы (1)
Программа спрашивает стороны прямоугольника, находим площадь и выводим на экран результат. Далее программа спрашивает любое число если число делиться на 5 выводит на экран сообщение число кратно 5 иначе выводит сообщение число не кратно 5 далее
Ответы (1)
Написать программы на языке С++ 1) С клавиатуры вводится 2 числа - целое и вещественное. Программа выводит их сумму на экран.
Ответы (1)