Задать вопрос
3 июня, 22:22

Найти сумму нечетных цифр в заданном с клавиатуры числе.

+4
Ответы (1)
  1. 4 июня, 01:13
    0
    Var

    str : string;

    i, c, a, count : integer;

    begin

    i:=1;

    count : = 0;

    writeln ('Вводите числа, как только введете все числа нажмите любую букву') ;

    while i=1 do begin

    readln (str) ;

    val (str, a, c) ;

    if (a mod 2 0) then count : = count + a;

    if (c0) then i:=0;

    end;

    writeln ('Сумма нечетных чисел = ', count) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти сумму нечетных цифр в заданном с клавиатуры числе. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Вводится целое положительное число. Найти наименьшую нечетную цифру в числе. Если в числе нет нечетных цифр, то вывести надпись "В числе нет нечетных цифр"
Ответы (1)
Паскаль, цикл с предусловием while. Вводится целое положительное число. Найти наименьшую нечетную цифру в числе. Если в числе нет нечетных цифр, то вывести надпись "В числе нет нечетных цифр"
Ответы (1)
1) Найти минимальное число, большее 300, которое нацело делится на 19.2) С клавиатуры вводится натуральное число n. Найти количество цифр этого числа, их сумму, количество четных и нечетных цифр, сколько цифр в числе делится на 3.
Ответы (1)