Задать вопрос
7 февраля, 11:43

Написать программу для вычисления суммы элементов заданного числового массива

+5
Ответы (1)
  1. 7 февраля, 13:26
    0
    program massiv6;

    02. uses crt;

    03. const N=10;

    04. type x=array [1 ... N] of integer;

    05. var a:x;

    06. i:integer;

    07. s:integer;

    08. begin

    09. clrscr;

    10. randomize;

    11. for i:=1 to N do

    12. begin

    13. a[i]:=-100+random (201) ;

    14. write (A[i]:5)

    15. end;

    16. writeln;

    17. s:=0;

    18. for i:=1 to N do

    19. if a[i]>0 then

    20. begin

    21. s:=s+a[i]

    22. end;

    23. writeln (‘Сумма положительных элементов = ’, s:5) ;

    24. readln

    25. end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу для вычисления суммы элементов заданного числового массива ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Написать программу, позволяющую для заданного одномерного массива А из n вещественных или целых элементов реализовать обработку массива. Длина массива N задается пользователем как константное выражение.
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)