Задать вопрос
28 февраля, 04:16

Составить в Паскале программу. Пользователь должен ввести число. Затем, если число положительное (больше нуля), то умножаем его на 2, иначе прибавляем к числу 1.

+3
Ответы (1)
  1. 28 февраля, 05:34
    0
    Program p1;

    var

    num: integer;

    begin

    write ('Введите число: ') ;

    readln (num) ;

    if num > 0 then

    writeln ('Вывод: ', num * 2)

    else

    writeln ('Вывод: ', 1 + num) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить в Паскале программу. Пользователь должен ввести число. Затем, если число положительное (больше нуля), то умножаем его на 2, иначе ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Какое событие наступит после того, как: А) ученик встретит учителя Б) пользователь выберет команду меню В) пользователь выберет объект правой кнопкой мыши Г) пользователь включит компьютер Д) пользователь перетянет левый нижний угол окна
Ответы (1)
1) Ввести число. Если оно неотрицательно (больше 0), вычесть из него 10, иначе - прибавить к нему 10 2) Ввести 2 числа.
Ответы (1)
Напишите на языке C++! 1) Ввести число. Если оно неотрицательно (больше 0), вычесть из него 10, иначе - прибавить к нему 10 2) Ввести 2 числа.
Ответы (1)
Напишите программу на паскале А. выясните какие числа ввел пользователь: положительное или отрицательное? Б. выясните какие числа ввел пользователь: четное или нечетное?
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)