Задать вопрос
12 апреля, 07:34

Помогите решить задачу по Pascal ABC, цикл while. C клавиатуры вводится число, ввод заканчивается числом 500. Сколько чисел делится на 3?

+5
Ответы (1)
  1. 12 апреля, 08:52
    0
    Var col, ch:integer;

    begin

    writeln ('введите числа, закончив ввод числом 500 ') ;

    while (ch500) do begin

    readln (ch) ;

    if ch mod 3 = 0 then col:=col+1;

    end;

    writeln ('количество чисел кратных трём = ', col) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите решить задачу по Pascal ABC, цикл while. C клавиатуры вводится число, ввод заканчивается числом 500. Сколько чисел делится на 3? ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Найти: а) сумму всех целых чисел от 100 до 500; б) сумму всех целых чисел от a до 500 (значение a вводится с клавиатуры; a 500) ; в) сумму всех целых чисел от - 10 до b (значение b вводится с клавиатуры; b - 10) ;
Ответы (1)
напишите программу на языке паскаля через цикл while, которая определяет максимальное из введенных чисел с клавиатуры (ввод чисел заканчивается числом 0).
Ответы (1)
Составить программу на языке pascal. используя цикл repeat ... until. Определить минимальное число из введенной с клавиатуры последовательности положительных чисел, ввод заканчивается отрицательным числом.
Ответы (1)