Задать вопрос
28 марта, 23:07

Помогите с Паскалем. Надо составить программу.

1) У наибольшего из чисел x, y, z найти цифру младшего разряда (единиц) и остаток от его деления на 3.

2) Написать программу, которая по номеру дня недели выдаёт количество уроков на следующий день.

+4
Ответы (2)
  1. 28 марта, 23:47
    0
    Согласно первому заданию надо сначала найти максимальный элемент

    uses crt;

    var x, y, z, max:integer;

    Begin

    writeln ('Введите x y z') ;

    readln (x, y, z) ;

    if (x>y) and (x>z)

    then max:=x

    else

    if (y>x) and (y>z)

    then max:=y

    else max:=z;

    Writeln ('max = ', max) ;

    Writeln ('Младший разряд = ', max mod 10) ;

    Writeln ('Остаток от деления на 3 = ', (max mod 10) mod 3) ;

    readln;

    end.

    2)

    var n: Integer;

    Begin

    writeln ('Введите день недели') ;

    readln (n) ;

    write ('Уроков ') ;

    case n of

    1-4: writeln ('6') ;

    5,6: writeln ('5') ;

    7: writeln ('нет') ;

    end;

    End.
  2. 28 марта, 23:49
    0
    2. var n: Integer;

    Begin

    readln (n) ;

    write ('Уроков ') ;

    case n of

    1: writeln ('6') ;

    2: writeln ('6') ;

    3: writeln ('6') ;

    4: writeln ('5') ;

    5: writeln ('5') ;

    6: writeln ('нет') ;

    7: writeln ('6') ;

    end;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите с Паскалем. Надо составить программу. 1) У наибольшего из чисел x, y, z найти цифру младшего разряда (единиц) и остаток от его ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Информатика. 5 Класс. С использованием Оператора выбора. С клавиатуры вводится число - номер дня недели. По номеру дня недели определить и вывести количество уроков в этот день.
Ответы (1)
Написать программу на С++, которая по номеру дня недели (целому числу от 1 до 7) выдаёт в качестве результата количество уроков в вашем классе в этот день. Реализовать программу через функцию
Ответы (1)
Написать программу, которая по номеру дня недели (натуральному числу от 1 до 7) выдает в качестве результата количество уроков в Вашем классе в этот день. (7 урок каждый день)
Ответы (1)
Составить программу, которая находит минимальное натуральное число х, такое, что остаток от деления х на 10 равен 9, остаток от деления х на 9 равен 8, остаток от деления х на 8 равен 7, ... остаток от деления х на 2 равен 1.
Ответы (1)
Автомат получает на вход нечётное число X. По этому числу строится трёхзначное число Y по следующим правилам. 1. Первая цифра числа Y (разряд сотен) - остаток от деления X на 4. 2. Вторая цифра числа Y (разряд десятков) - остаток от деления X на 3.
Ответы (1)