Задать вопрос
28 мая, 09:43

Как написать программу "Бегущая строка" на языке Паскаль?

+4
Ответы (1)
  1. 28 мая, 11:24
    0
    Uses Crt;

    Procedure Beg (x, y, Len : Byte; S : String) ;

    Var i : Byte;

    Begin

    For i:=1 to Len do S:=' '+S+' ';

    Repeat

    GoToXY (x, y) ;

    Writeln (Copy (S, 1, Len)) ;

    Delete (S, 1,1) ;

    Delay (100) ;

    Until Length (S)
    end;

    Begin

    Beg (10,10,20,'Внимание! Совершает посадку рейс №123 маршрут Москва-Владивосток! Просьба встречающих пройти к выходу терминала №3.') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Как написать программу "Бегущая строка" на языке Паскаль? ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Задача_1: Составить программу на языке Паскаль для вычисления выражения y:=sqr (x) + x/3+sqr (sin (x)) Задача_2: Составить программу на языке Паскаль для вычисления площади треугольника по трем сторонам (подсказка: это формула Герона) Задача_3:
Ответы (1)
1) Написать программу на языке Паскаль, которая вычисляет среднее арифметическое пяти любых чисел. 2) Написать программу на языке Паскаль, вычисляющую корни квадратного уравнения.
Ответы (1)
Написать программу на языке Паскаль. 1. Написать программу из 3 введенных значений. Найти максимальное 2. Написать программу запрашивающую номер класса и выводящееся сообщения если 1-4 класса-младшая школа, 5-9-средняя, 10-11-старшая 3.
Ответы (1)