Задать вопрос
4 ноября, 20:53

Как в паскале записать программу, решающее выражение 7 х²-2 (х-3) / х-3?

Проводится работа с операторами (если, то, иначе) и при написании вылезает ошибка 1001 "переменной не присвоено значение". Что делать, спасите?

+4
Ответы (1)
  1. 4 ноября, 21:39
    0
    VAR

    x, a, b: Integer;

    y: Real;

    Begin

    WriteLn ('Введите x') ; ReadLn (x) ;

    if x = 3 then begin

    WriteLn ('Знаменатель равен 0!') ;

    end else begin

    a: = x - 3;

    b: = 7 * x * x - a * 2;

    y:=b / a;

    WriteLn (y) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Как в паскале записать программу, решающее выражение 7 х²-2 (х-3) / х-3? Проводится работа с операторами (если, то, иначе) и при написании ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Как решить по информатике тема система счисления примеры вот х 101 y 1001 х 1 у 1001 х 101 у 11 х 1001 у 110 у
Ответы (1)
Зачетная работа по информатике. 1. Написать программу вычисления площади прямоугольника (на паскале). 2. Написать программу вычесления ускорения тела (на паскале).
Ответы (1)
написать программу на Паскале: А) Условие задачи №1: если введенное целое число является трехзначным, то удалить из него среднюю цифру; если число двухзначное, то удвоить крайние цифры; иначе - выдать сообщение "Ошибка ввода".
Ответы (1)
Что получится в результате работы следующего алгоритма, если 1) a=2, b=5, 2) a=0, b=-2 алг пример цел a, b, c нач ввод a, b если a>0 то если b>0 то c:=a+b иначе c:=10 кв иначе если b>0 то c:=a*b иначе c:=0 кв кв вывод c кон
Ответы (2)
Что получится в результате работы следующего алгоритма, если 1) a=2, b=5, 2) a=0, b=-2 алг пример цел a, b, c нач ввод a, b если a >0 то если b>0 то c:=a+b иначе c:=10 кв иначе если b>0 то c:=a*b иначе c:=0 кв кв вывод c кон
Ответы (1)