Задать вопрос
8 марта, 23:15

Паскаль составьте программу определения наибольшей цифры в записи данного натурального числа

+1
Ответы (1)
  1. 9 марта, 00:22
    0
    Program prog;

    uses crt;

    var x, y:integer;

    begin

    clrscr;

    write ('x = ') ;

    readln (x) ;

    while abs (x) >0 do begin

    if abs (x mod 10) >y then y: = abs (x mod 10) ;

    x: = x div 10;

    end;

    writeln ('Наибольшая цифра чсла = ', y) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль составьте программу определения наибольшей цифры в записи данного натурального числа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Составьте программу (Паскаль) для определения количества цифр в записи произвольного натурального числа. Сейчас проходим while, судя по всему его и надо использовать.
Ответы (1)
Задача_1: Составить программу на языке Паскаль для вычисления выражения y:=sqr (x) + x/3+sqr (sin (x)) Задача_2: Составить программу на языке Паскаль для вычисления площади треугольника по трем сторонам (подсказка: это формула Герона) Задача_3:
Ответы (1)
Паскаль! составьте алгоритм для определения количества цифр в записи произвольного натурального числа
Ответы (1)