Задать вопрос
21 ноября, 16:44

Напишите программу, которая принимает с клавиатуры целое число и проверяет, на какое количество двузначных чисел оно делится.

Результат проверки класс должен вывести на экран вместе с соответствующим текстовым сообщением.

+1
Ответы (1)
  1. 21 ноября, 18:34
    0
    На паскаль

    var i, j, k:longint;

    begin

    read (i) ;

    if i < 10 then write ('Число меньше 10. Поэтому оно не имеет двузначный делитель') ;

    for j:=10 to 99 do

    if i mod j=0 then inc (k) ;

    if k=0 then write ('Ваше число не имеет двузначный делитель') else write ('Ваше число имеет ', k,' делителей') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая принимает с клавиатуры целое число и проверяет, на какое количество двузначных чисел оно делится. Результат ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
1. Прочитать с клавиатуры число n, затем прочитать n чисел и вывести на экран сумму тех из них, которые делятся на 3. 2. Прочитать с клавиатуры число n и вывести на экран сумму его четных цифр 3.
Ответы (1)
1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа. 2. Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки. 3.
Ответы (1)