Задать вопрос
23 мая, 15:48

Составить алгоритм блок схему и программу для решения задачи ввести число если оно положительное разделить на 4 если отрицательное или равно нулю умножить на 5

+3
Ответы (1)
  1. 23 мая, 17:21
    0
    Ох, ну блок-схема вот: в ромбе: n>0, далее + и в прямоугольнике n: = div 4, или n<=0, в прямоугольнике n:=n*5, далее конец

    var

    n:integer;

    read (n) ;

    write ('напишите n') ;

    begin

    if n>0 then

    n:=n div 4

    else

    n:=n*5;

    read (n) ;

    end;

    end.

    Могла с составлением программы ошибиться.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить алгоритм блок схему и программу для решения задачи ввести число если оно положительное разделить на 4 если отрицательное или ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
1. Составьте блок-схему для решения задачи: Найти площадь S и периметр P прямоугольника. Значения сторон а и в задать произвольно. 2. Составить блок - схему кипячения чайника. 3. Составить алгоритм сбора яблок в саду.
Ответы (1)
Составить программу, которая запрашивает целое число, не равное нулю, сообщает, положительное оно или отрицательное. и при этом положительное число уменьшает в 2 раза, а отрицательное возводит в квадрат.
Ответы (1)
Составить программу в паскале Ввести число. Если оно четное и положительное, разделить его на 4, если четное и отрицательное - умножить на 5, если нечетное - возвести в квадрат.
Ответы (1)
Напишите программу вывода на экран фразы "Число положительное", если введенное число положительное, и "Число отрицательное", если введенное число отрицательное.
Ответы (1)