Задать вопрос
7 октября, 16:22

Даны 3 двухзначных числа. Выяснить, сколько из них начинаются цифрой 7?

+5
Ответы (1)
  1. 7 октября, 17:17
    0
    Const

    n=3;

    var

    x, i, count: integer;

    begin

    for i:=1 to n do

    begin

    read (x) ;

    if (x div 10) = 7 then inc (count) ;

    end;

    writeln (count) ;

    end.

    Проверка работы:

    Введенные данные:

    56 76 73

    Вывод:

    2
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны 3 двухзначных числа. Выяснить, сколько из них начинаются цифрой 7? ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу по выдаче рандомных чисел, содержащих от 1 до 5 знаков, состоящих из чисел от 1 до 12, так чтобы: За цифрой 1 могли следовать только цифры 4, 5, 7, 9, 10 За цифрой 2 - только 5, 6, 8, 10, 11 За цифрой 3 - только 6, 7, 9, 11, 12 За
Ответы (1)
Автомат получает на вход три двухзначных числа. По этим числам строится новое число по следующим правилам. 1. Вычисляются два числа - сумма старших разрядов заданных двухзначных чисел и сумма младших разрядов. 2.
Ответы (1)
1. Даны 3 числа А, В и С. Значение наибольшего из них удвоить. 2. Даны 3 числа А, В и С. Выяснить существует ли треугольник со сторонами А, В, С.
Ответы (1)
1. Даны целые числа b1, b2, ..., b10. Выяснить: а) верно ли, что сумма тех из них, которые больше 20, превышает 100; б) верно ли, что сумма тех из них, которые меньше 50, есть четное число.
Ответы (1)
Вариант 2 1. Даны три числа. Найдите сумму второго и третьего числа. Найдите квадрат первого числа. 2. Даны длины сторон прямоугольника. Найдите площадь прямоугольника. 3. Даны длины катетов прямоугольного треугольника. Найдите периметр треугольника.
Ответы (1)