Задать вопрос
25 февраля, 01:16

Напишите программу, которая показывает количество нечетных чисел в числе. (если можно, то без программы while и не слишком мудро)

+4
Ответы (1)
  1. 25 февраля, 02:10
    0
    Var

    k:longint;

    d, n:integer;

    begin

    Write ('Введите натуральное число (1-2147483647) : ') ;

    Read (k) ;

    n:=0;

    while k>0 do begin

    d:=k mod 10;

    k:=k div 10;

    if (d mod 2) 0 then Inc (n)

    end;

    Writeln ('Количество нечетных цифр в числе равно ', n)

    end.

    Тестовое решение:

    Введите натуральное число (1-2147483647) : 35632105

    Количество нечетных цифр в числе равно 5
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая показывает количество нечетных чисел в числе. (если можно, то без программы while и не слишком мудро) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Какие программы относятся к прикладным программам? A. Программы общего назначения. B. Специальные профессиональные программы. C. Языки программирования. D. Сервисные программы. E. Операционные системы.
Ответы (1)
Паскаль, цикл с предусловием while. Вводится целое положительное число. Найти наименьшую нечетную цифру в числе. Если в числе нет нечетных цифр, то вывести надпись "В числе нет нечетных цифр"
Ответы (1)
Антивирусные программы-это 1. программы сканирования и распознавания 2. программы выявляющие и лечащие компьютерные вирусы 3. программы только выявляющие вирусы 4. программы-архиваторы разархиваторы
Ответы (1)
Напишите программу, которая в последовательности натуральных чисел определяет сумму и количество чисел нечетных чисел кратных 5. Программа получает на вход количество чисел в последовательности, а затем сами числа.
Ответы (1)