Задать вопрос
8 ноября, 13:48

Помогите напишите задачу и ее решение в паскале.

Массивы

Составить программу для решения следующей задачи:

Дан массив целых чисел. Выяснить какой элемент массива больше, k-й или p-й.

+2
Ответы (1)
  1. 8 ноября, 14:09
    0
    Var a, b, c:integer;

    n:array [1 ... 10] of integer;

    begin

    writeln ('введите номера элементов для сравнения') ;

    readln (a, b) ;

    randomize; {скажите что посмотрели эту функцию в интернете и она нужна для подготовки программы к применению функции рандом}

    for c:=1 to 10 do begin

    n[c]:=random (-20,20) ; {так мы в массив ставим случайное число в диапазоне от - 20 до 20}

    writeln (n[c]) ;

    end;

    if n[a]
    else writeln ('меньший элемент массива под номером ', b,' больший элемент массива под номером ', a) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите напишите задачу и ее решение в паскале. Массивы Составить программу для решения следующей задачи: Дан массив целых чисел. Выяснить ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Помогите с информатикой 1. Что такое массив? 2. Что такое элемент массива? 3. Что такое индекс массива? 4. Что такое размерность массива? 5. Зачем нужны массивы? 6. Как можно обратиться к ячейке массива? 7. Какого типа могут быль элементы массива? 8.
Ответы (1)
Дан массив целых чисел. Выяснить: 1) является ли s-й элемент массива положительным числом; 2) является ли k-й элемент массива чётным числом; 3) какой элемент массива больше k-й или s-й. Паскаль для Лазаруса.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)