Задать вопрос
27 октября, 11:04

Написать алгоритм факториала в паскале

+1
Ответы (1)
  1. 27 октября, 14:49
    0
    Var

    i, n: integer;

    f: longint;

    begin

    Write ('Задайте натуральное число: ') ; Readln (n) ;

    f : = 1;

    for i : = 2 to n do f : = f * i;

    Writeln (n, '!=', f)

    end.

    Тестовое решение:

    Задайте натуральное число: 5

    5!=120
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать алгоритм факториала в паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Построить блок-схему и написать программу 1. Вычислить S=1+2+3+4+ ...+N 2. Для данного N составить алгоритм вычисления факториала N!=1*2*3* ...*N
Ответы (1)
исключи из предложенных сочетаний слов те, которые невозможны в информатике: 1) линейный алгоритм 2) прямой алгоритм 3) циклический алгоритм 4) разветвляющийся алгоритм
Ответы (2)
Алгоритм выполнения домашнего задания. Алгоритм рецепта приготовления пирога. Алгоритм мытья посуды. Алгоритм путешествия Колобка в известной сказке. Оформление.
Ответы (1)
Какой алгоритм называется линейным? А. Алгоритм, в котором имеется ввод данных, вычисления и вывод результатов. Б. Алгоритм, в котором для получения результатов последовательно выполняются все операторы по одному разу В.
Ответы (1)
Если данное предложение представить в виде алгоритма то это будет: Если сделаешь уроки, то можешь пойти в кино, иначе сиди дома. А) Линейный алгоритм В) Алгоритм с ветвлением С) Комбинированный алгоритм D) Алгоритм с циклом
Ответы (1)