Задать вопрос
21 октября, 09:20

Паскаль. задача: входим в магазин, дают сдачу копейками от 1 до 100, определить окончание для всех чисел. с помощью "case". т. е.

1,21,31,41 ... 91-копейка

2 ... 4,22 ... 24,32 ... 34 ... - копейки

5 ... 20,25 ... 30-копеек

только методом деления числа

+2
Ответы (1)
  1. 21 октября, 11:09
    0
    Pascal ABC

    Первый вариант с вводом числа с клавы, второй с циклом For

    1)

    Var A:integer;

    S:string;

    Begin

    Write ('Сумма сдачи = ') ; Read (A) ;

    if (A>10) and (A<21) then S: = ' копеек'

    else

    Case A mod 10 of

    1:S:=' копейка';

    2 ... 4:S:=' копейки';

    0,5 ... 9:S:=' копеек';

    End;

    WriteLn (A, S) ;

    End.

    2)

    Var

    A:integer;

    S:string;

    Begin

    For A: = 1 to 100 do

    Begin

    if (A>10) and (A<21) then S: = ' копеек'

    else

    Case A mod 10 of

    1:S:=' копейка';

    2 ... 4:S:=' копейки';

    0,5 ... 9:S:=' копеек';

    End;

    WriteLn (A, S)

    End

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль. задача: входим в магазин, дают сдачу копейками от 1 до 100, определить окончание для всех чисел. с помощью "case". т. е. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Написать программу в паскале, которая после введенного с клавиатуры числа (в диапазоне от 1 до 99), обозначающий денежную единицу, дописывал слово "Копейка". Например, 5 копеек, 41 копейка и тд.
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Автомат получает на вход нечётное число X. По этому числу строится трёхзначное число Y по следующим правилам. 1. Первая цифра числа Y (разряд сотен) - остаток от деления X на 4. 2. Вторая цифра числа Y (разряд десятков) - остаток от деления X на 3.
Ответы (1)
Составить программу, которая находит минимальное натуральное число х, такое, что остаток от деления х на 10 равен 9, остаток от деления х на 9 равен 8, остаток от деления х на 8 равен 7, ... остаток от деления х на 2 равен 1.
Ответы (1)