Задать вопрос
2 октября, 22:10

Вводиться файл из натуральных чисел.

Требуется отсортировать числа

в файле в порядке возрастания.

+4
Ответы (1)
  1. 2 октября, 22:22
    0
    Замечание: данные в файле должны быть записаны по одному числу в строке.

    const

    m=100; { максимальное количество чисел в файле }

    var

    f:Text;

    i, j, n, k:integer;

    a:array[1 ... m] of integer;

    begin

    { читаем данные из файла в массив }

    Assign (f,'SuperFile. txt') ; Reset (f) ;

    i:=0;

    while not Eof (f) do begin Inc (i) ; Readln (f, a[i]) end;

    Close (f) ;

    n:=i;

    { сортируем массив по возрастанию методом пузырька }

    for i : = 1 to n-1 do

    for j : = 1 to n-i do

    if a[j] > a[j+1] then

    begin k : = a[j]; a[j] : = a[j+1]; a[j+1] : = k end;

    { заполняем файл из массива }

    Rewrite (f) ;

    for i:=1 to n do Writeln (f, a[i],' ') ;

    Close (f)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вводиться файл из натуральных чисел. Требуется отсортировать числа в файле в порядке возрастания. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан символьный файл f. Записать в файле g, с сохранением порядка их следования, те символьные данные: a) которым в файле f предшествует буква а б) в след за которыми в файле f идёт буква а
Ответы (1)
Открыть в редакторе Microsoft Word произвольный текстовый файл (без графических элементов), определить количество символов в этом файле, включая пробелы (команда Файл - " Свойства), и вычислить количество информации в этом файле.
Ответы (1)
Почему файл, созданный в Word 2007, имеет расширение. docm? Вариант 1 файл предназначен для пересылки по электронной почте Вариант 2 файл содержит вирусы Вариант 3 файл создан на основе шаблона Вариант 4 файл содержит макросы
Ответы (1)
Сравнение файлов Первый файл на 1 мегабайт больше, чем второй файл. Второй файл на 3072 байта больше, чем третий файл. На сколько килобайт третий файл меньше, чем первый? В ответе укажите только число, слово "килобайт" писать не надо.
Ответы (1)
Фоксфорд олимпиада по информатикеПервый файл на 1 мегабайт больше, чем второй файл. Второй файл на 3072 байта больше, чем третий файл. На сколько килобайт третий файл меньше, чем первый? В ответе укажите только число, слово "килобайт" писать не надо.
Ответы (1)