Задать вопрос
7 ноября, 04:50

Напишите программу для Pascal. Пользователь с клавиатуры вводит любое четырехзначное число необходимо определить равна ли сумма тысяч и десятков сумме сотен и единиц и вывести соответствующий ответ на экран Например: 3671 - нет 3641 - да

+4
Ответы (1)
  1. 7 ноября, 05:16
    0
    Var a:integer;

    begin

    readln (a) ;

    if (a div 1000 + (a div 10) mod 10 = a mod 10 + (a div 100) mod 10) then writeln ('yes')

    else writeln ('no') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу для Pascal. Пользователь с клавиатуры вводит любое четырехзначное число необходимо определить равна ли сумма тысяч и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
С++ Так что бы программа просила в вести значение на русском 1. Напишите программу, которая вычисляет сумму целых чисел от а до 500 (значение a вводится с клавиатуры). 2. Найти среднее арифметическое всех целых чисел от 1 до 1000. 3.
Ответы (1)
Программирование в python 3 Напечатать массив и сумму его первых N десятков. Пример: Пользователь вводит любое число, например 56 Программа выдаёт на экран массив от 0 до 55 и ещё пять чисел: сумму первых 10, сумму первых 20, сумму первых 30, сумму
Ответы (1)
2) Вводится четырехзначное число с клавиатуры. Определить цифру тысяч, сотен, десятков и единиц. В окне вывода должно быть так (это пример) Введи четырехзначное число: 1234 цифра тысяч-1 цифра сотен-2 цифра десятков-3 цифра единиц - 4
Ответы (1)
Вводится четырехзначное число с клавиатуры. Определить цифру тысяч, сотен, десятков и единиц. В окне вывода должно быть так (это пример) Введи четырехзначное число: 1234 цифра тысяч-1 цифра сотен-2 цифра десятков-3 цифра единиц - 4
Ответы (1)
1) Составьте программу на языке Pascal, в которой пользователь вводит с клавиатуры значения элементов массива, а программа выводит значения элементов массива с противоположным знаком.
Ответы (1)