Задать вопрос
12 февраля, 04:08

Написать программу, которая находит количество нулей в заданном числе. На языке программирования Pascal

+2
Ответы (1)
  1. 12 февраля, 05:33
    0
    Ну здесь все очень просто

    Я надеюсь вы знакомы уже с типо данных String

    var s:string;

    i, n:integer;

    begin

    readln (s) ;

    for i:=1 to length (s) do

    if (s[i] = '0') then inc (n) ;

    write (n) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, которая находит количество нулей в заданном числе. На языке программирования Pascal ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Отметьте истинные утверждения о языках программирования: 1). Языки программирования бывают универсальными и специализированными. 2). Язык программирования Python - универсальный язык программирования. 3).
Ответы (1)
На языке программирования Паскаль напишите программу, которая: 1) В последовательности чисел находит количество чисел, кратных 3. 2) В последовательности чисел находит максимальное четное число, оканчивающееся на 4.
Ответы (1)
Задание: 1) Перечислить виды циклов. 2) Конструкция цикла с параметром на языке программирования Pascal. 3) Известно ли число повторений в цикле с параметром? 4) Если известно, то указать формулу, по которой можно определить число повторений.
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
Написать на языке pascal. Дан массив с1, с2 ... с15 состоящий из нулей и единиц. Подсчитать количество 0, количество 1, и количество нулей до первой единицы
Ответы (1)