Задать вопрос
7 августа, 16:51

Даны числа a и b найти общие делители

P. S. На Паскале

+4
Ответы (1)
  1. 7 августа, 17:03
    0
    Var

    a, b, i: integer;

    begin

    readln (a, b) ;

    for i:=1 to max (a, b) do

    if (a mod i = 0) AND (b mod i = 0) then

    write (i, ' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны числа a и b найти общие делители P. S. На Паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Два множества: первое все простые делители некоторого целого числа N и второе все простые делители того же числа. Вывести на экран делители которые не являются простыми. (Паскаль)
Ответы (1)
Найти все простые делители натурального числа N. Входные данные: Ввести одно число N (1
Ответы (1)
Всё надо сделать на паскале. a) x^5 b) x^6 c) x^8 d) x^9 e) x^10 2 задание: Дан диаметр окружности d. Найти его длину (L=П*d) 3 задание: Найти длину окружности L и площадь круга S заданного радиуса R: L=2πR, S = πR^2 4 задание: Даны 2 числа a и b.
Ответы (1)
Выведите все натуральные делители числа x в порядке возрастания (включая 1 и само число). Входные данные Вводится натуральное число x Выходные данные Выведите все делители числа x Примеры входные данные 7 выходные данные 1 7 входные данные 21
Ответы (1)
Хотя бы что-нибудь! Помогите решить задачи в паскале! Составить программу для: 1) Решения линейного уравнения ах + в = 0 (а, в ≠ 0).
Ответы (1)