Задать вопрос
31 января, 05:15

Найти все простые делители натурального числа N. Входные данные: Ввести одно число N (1<=N<=200000000). Выходные данные: Вывести все простые делители натурального числа N в порядке их возрастания.

+1
Ответы (1)
  1. 31 января, 08:48
    0
    Var i, k, n, m: integer;

    begin

    write ('N = ') ; readln (n) ;

    m:=round (sqrt (n)) ;

    i:=2; k:=1;

    repeat

    if (n mod i=0) then

    begin

    if ik then

    begin

    write (i,' ') ;

    k:=i;

    end;

    n:=n div i;

    m:=round (sqrt (n)) ;

    i:=1;

    end;

    i:=i+1;

    until i>m;

    if kn then writeln (n) ;

    end.

    N = 43021568

    2 163 1031

    N = 625

    5

    N = 189756328

    2 67 354023
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти все простые делители натурального числа N. Входные данные: Ввести одно число N (1 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Выведите все натуральные делители числа x в порядке возрастания (включая 1 и само число). Входные данные Вводится натуральное число x Выходные данные Выведите все делители числа x Примеры входные данные 7 выходные данные 1 7 входные данные 21
Ответы (1)
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Входные данные Вводится натуральное число N, которое не превосходит 30. Выходные данные Вычислите 1+2+22+23+ ...+2 N. Примеры входные данные 1 выходные данные 3 входные данные 4 выходные данные 31
Ответы (1)
Напишите программу, которая выводит все простые числа Софи Жермен (такие, что для числа p число 2 p + 1 тоже простое) в диапазоне от K до N (2 ≤ K ≤ N ≤ 100000).
Ответы (1)