Задать вопрос
27 октября, 02:21

В программе обрабатывается одномерный целочисленный массив А с индексами от 0 до 9. Значения элементов равны 8; 5; 11; 4; 6; 9; 4; 10; 7; 8 соответственно, т. е. A[0]=8; a[1]=5 и т. д.

Определите значение переменной s после выполнения следующего фрагмента программы, записанного ниже на Паскале

k:=0; t:=0;

for i:=0 to 9 do

if A[i]>k then begin

t:=k;

k:=A[i]

end

else

t:=A[i];

S:=k+t;

+4
Ответы (1)
  1. 27 октября, 03:37
    0
    Const

    A: array of integer = (8, 5, 11, 4, 6, 9, 4, 10, 7, 8) ;

    var

    k, t, i, S: integer;

    begin

    k:=0; t:=0;

    for i:=0 to 9 do

    if A[i]>k then begin

    t:=k;

    k:=A[i]

    end

    else

    t:=A[i];

    S:=k+t;

    writeln (S) ;

    end.

    Ответ: 19
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В программе обрабатывается одномерный целочисленный массив А с индексами от 0 до 9. Значения элементов равны 8; 5; 11; 4; 6; 9; 4; 10; 7; 8 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
3. Определите значение переменной с после выполнения следующего фрагмента программы: a : = 30; b : = 14; a : = a - 2 * b; if a > b then c : = b + 2 * a else c : = b - 2 * a; 4.
Ответы (1)
1. определить значение переменной А после выполнения оператора X:=5; if X>-3 then A:=X mod 2 else A:=abs (X) ; 2. определить значение переменной А после выполнения оператора X:=-26; Y:=6; if X div Y=4 then A:=X mod Y else A:=X*Y; 3.
Ответы (1)
10. Определите значение переменной с после выполнения следующего фрагмента программы: a: = 5; a: = 12 - a*a; b: = - a; c: = 10*a - b; 11.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
В программе описан одномерный целочисленный массив A с индексами от 1 до 15. Ниже представлен фрагмент этой программы, в котором значения элементов массива сначала задаются, а затем меняются.
Ответы (1)