Задать вопрос
2 ноября, 02:58

Требовалось написать программу, которая определяет, имеется ли среди введенных с клавиатуры положительных целых чисел а и b хотя бы одно четное. Была

написана следующая программа:

var a, b: integer;

begin

readln (a, b) ;

a : = a mod 2;

if a > 0 then b : = b mod 2;

if b > 0 then

writeln ('четных чисел нет')

else

writeln ('четное число есть') ;

end.

Известно, что программа написана с ошибками. Последовательно выполните три задания:

укажите, как, по вашему мнению, нужно доработать программу (не используя слож-ные условия), чтобы не было случаев ее неправильной работы;

+3
Ответы (1)
  1. 2 ноября, 05:54
    0
    Var

    a, b:integer;

    Begin

    readln (a, b) ;

    if a mod 2 = 0 then writeln ('есть чётное')

    else if b mod 2=0 then writeln ('есть чётное')

    else writeln ('Нет чётных) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Требовалось написать программу, которая определяет, имеется ли среди введенных с клавиатуры положительных целых чисел а и b хотя бы одно ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Требовалось написать программу, 1) Требовалось написать программу, которая определяет, можно ли построить треугольник из отрезков с длинами х, у, z. Программа должна выводить соответствующее текстовое сообщение.
Ответы (1)
Какое число будет напечатано в результате выполнения программы: var i, k: integer; function f (x: integer) : integer; var m: integer; begin if x < 10 then f : = x else begin m : = f (x div 10) ; if m < x mod 10 then f : = x mod 10 else f : = m; end;
Ответы (1)
1) Требовалось написать программу, которая определяет, можно ли построить треугольник из отрезков с длинами х, у, z. Программа должна выводить соответствующее текстовое сообщение. Программист сделал в программе ошибки.
Ответы (1)
Укажите области видимости в программе: Program P; Var x: integer; Procedure P1; Var y: integer; Begin P2; End; Procedure P2; Var z: integer; Begin {Тело процедуры} End; Procedure P3; Var m: integer; Begin P1; End; Begin {Тело основной программы}P3;
Ответы (1)
5. Исходя из условия задачи, исправьте программу и напишите правильное решение Задача: Даны три целых числа A, B, C. Определить, есть ли среди них хотя бы одно четное и хотя бы одно нечетное.
Ответы (1)