Задать вопрос
4 октября, 13:25

1) Требовалось написать программу, которая определяет, можно ли построить треугольник из отрезков с длинами х, у, z. Программа должна выводить соответствующее текстовое сообщение. Программист сделал в программе ошибки.

var х, у, z: real;

begin

readln (x, у, z) ;

if (x + y > z) then

begin

if (x + z > y) then i

f (y + z > x) then

writeln ('треугольник построить можно') ;

end

else writeln ('треугольник построить нельзя') ;

end

Последовательно выполните задания: 1. Приведите пример таких чисел х, у, z, при которых программа неверно решает поставленную задачу. 2. Укажите, как нужно доработать программу, чтобы не было случаев ее неправильной работы (можно указать один из способов доработки исходной программы). 3. Укажите, как можно доработать программу, чтобы она вместо вложенных операторов IF содержала логическую операцию AND.

+2
Ответы (1)
  1. 4 октября, 16:20
    0
    1) Программист не сделал ошибки

    2) программа и так правильно работает

    3)

    program chik;

    var х, у, z:real;

    begin

    readln (x, у, z) ;

    if (x+y>z) and (x+z>y) and (y+z>x) then writeln ('треугольник построить можно') else writeln ('треугольник построить нельзя') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1) Требовалось написать программу, которая определяет, можно ли построить треугольник из отрезков с длинами х, у, z. Программа должна ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Требовалось написать программу, 1) Требовалось написать программу, которая определяет, можно ли построить треугольник из отрезков с длинами х, у, z. Программа должна выводить соответствующее текстовое сообщение.
Ответы (1)
Сделать так чтобы Writeln был заменен другим словом и повторялься не больше двух раз program choise; var N_M:integer; writeln (' введи номер месяца ') ; readln (N_M) ; case N_M of 1:writeln (' январь ') ; 2:writeln (' февраль ') ;
Ответы (1)
Имеется условный оператор:if D10 then writeln ('ура!') else writeln ('плохо ...') ; Какими операторами его можно заменить? Выберите несколько из 4 вариантов ответа: 1) if D=10 then writeln ('ура!') else writeln ('плохо ...
Ответы (1)
Где здесь ошибка program n_11; var a, b, c:Real; var d:Real; var x, x1, x2:Real; begin WriteLn ('Расширение квадратного уровнения') ; Write ('Введите коофиценты a, b, c >>') ; ReadLn (a, b, c,) ; d:=b*b-4*a*c;
Ответы (1)
Требовалось написать программу, которая вводит с клавиатуры координаты точки на плоскости (x, y - действительные числа) и определяет принадлежность точки заштрихованной области, включая ее границы.
Ответы (1)